Calendar Pro - Slow loading times

Incident Report for Witivio

Resolved

After 12 hours of monitoring with no further loading issues, we are closing this incident and marking it as resolved.
Posted Jun 03, 2025 - 07:52 CEST

Monitoring

The issue is resolved, but some users may still see a blank screen or “Impossible to reach this app.” If this happens, please clear your Teams cache by following these steps: https://learn.microsoft.com/en-us/microsoftteams/troubleshoot/teams-administration/clear-teams-cache
Posted Jun 02, 2025 - 18:28 CEST

Investigating

Calendar Pro is experiencing slow loading times. In some cases, it may not load at all. This is due to a current update, and we expect it to be resolved today. Please do not remove the Calendar Pro tab—removing it may result in data loss.
Posted Jun 02, 2025 - 16:32 CEST
This incident affected: TeamsPro (Calendar Pro).