The incident has been fully resolved. Should you experience any further issues, please don’t hesitate to contact our Customer Support team via the Admin Center.
Posted Jul 11, 2025 - 16:49 CEST
Identified
The issue has been identified and we're deploying the solution.
Posted Jul 11, 2025 - 11:38 CEST
Investigating
We’re currently investigating an issue affecting the synchronization between Outlook calendars and Calendar Pro. Some users may be experiencing difficulties during this time. We’ll share updates as soon as more information becomes available.