Calendar Pro unusual response time
Incident Report for Witivio
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 19:32 CEST
Investigating
🚧 Service Alert: We're currently experiencing slower than usual response times with Calendar Pro. Our team is actively working to resolve this. Thank you for your patience and understanding. 🚧
Posted Sep 18, 2023 - 17:13 CEST
This incident affected: TeamsPro (Calendar Pro).